SeeSnake Support:Home/HQ Online Manual

HQ Online Manual

HQ is a free desktop software tool that helps you collect digital pipe inspection content that includes video, audio, pictures, and text to impress your customer with simple to create yet professional looking reports. Use HQ to organize and edit inspection jobs, store customer information, customize and distribute reports in multiple formats, and update equipment software.

System Requirements

  • Windows 7, Windows 8, Windows 8.1, Windows 10.
  • Intel® Core i5 or AMD equivalent or higher. 1.84 GHz  (2.4 GHz or higher recommended)
  • 2 GB system memory (4 GB or higher recommended)
  • DirectX 9/10/11 compatible graphics integrated/dedicated with 256MB or higher (512 MB or higher dedicated graphics card recommended)
  • DirectX 9 or higher compatible sound card
  • 30 GB of disk space
  • 1 USB 2.0 port (USB 3.0 or USB Type-C Optional)
  • Screen resolution of 1024×768 (1280×800 or higher recommended)

Optional:

  • DVD burner for creating DVD reports
  • Internet connection for emailing reports, uploading reports to YouTube or RIDGID Connect, and software updates

HQ Tutorial Videos

Software Updates for HQ

It’s important to keep your HQ software updated. The most recent version has many enhancements and bug fixes that might resolve any issues as well as improve functionality.

Automatic Software Updates

HQ is set up to check software updates automatically so you don’t have to.

  • The updater will always prompt you to install updates and will never install an update without permission.
  • You will have to be connected to the internet before HQ can download any software updates.

Manual Software Updates

The Recommended Method to manually check for software updates within HQ:

  • Click on Updates from the Main Screen in HQ > Update HQ Software.
  • You will have to be connected to the internet before HQ can download any software updates.

Software Updates for your SeeSnake Equipment

The exclamation point icon next to your SeeSnake equipment indicates a software update is available. You may also see alerts in the Notification area to alert you that an update can be downloaded.

To update the software on your SeeSnake device using HQ:

  • Click the updates button at the top of HQ. You must be connected to the internet to download the update.
  • Select your device type and model from the drop down list and Insert a USB thumb drive/flash drive into your computer.
  • Follow the on-screen instructions, and choose the drive location to download and extract the update to.
  • Once downloaded, simply insert the USB thumb drive into the SeeSnake Equipment, power it up and agree to install the update when it prompts you.
  • The process will take a several minutes and your device may reboot a few times before it is complete.

The HQ Home Window

  • The Home Window is where you will manage and organize all your inspection jobs, and access most of the functions and features. It is the first screen you see when opening HQ, and will serve as the main software hub for all your inspection jobs, equipment, and notifications. SeeSnake HQ settings, menus, and sub-menus can be accessed from the Home Window.
  • Job in HQ is a container for all the information related to an inspection report including video, still-pictures, Autolog video, and Photo Talk, along with location/customer information and text notes. Jobs provide the data necessary to make a Report. Jobs are automatically assembled from photos and video clips taken from SeeSnake pipe inspection equipment. Job report distribution methods include YouTube uploadsRidgid Connect, email, DVD, USB drive, print, and webpage reports.

Most common functions of the main HQ screen or Home Window.

  • Create a new job: Select File > New, or click the New Job Button.
  • Import a job: Put a USB flash drive in your computer containing jobs from SeeSnake camera reel monitors, and HQ will import the jobs automatically. Import Jobs Video
  • Select a job: Click on the empty box to the far left of the job, and this will check the box and highlight the selected job.
  • Open a job: Select File > open job, or click the Open Button, or a third option, double-click a job from the main list.
  • Archive a job: Select the job and click the Archive Button.This removes the job from the main list, but does not delete the job.
  • Delete a job: Select the job and click the Delete Button. This will not permanently delete the job, it will move it to the Recycle Bin by default.
  • Recycle a job: When jobs are deleted, they are moved to the Recycle Bin. These jobs can be restored or permanently deleted.
  • Sort Jobs: You can change the sort order of your jobs by name, date, customer, etc. by clicking the categories on top of the home window where the list of your jobs appear.
  • Job Columns and Status: Useful to see job status, sort jobs, and select jobs.

Job Preview

  • The details/preview area show the media elements in the selected Job.
  • Right-click on a media element to email or copy and paste it into a document. Hit Ctrl to select multiple media elements.
  • To collapse or expand the details pane, double click on it.

Job Space, Equipment Locker, and Notifications

On the left side of HQ is where you see:

  • File Menu: Used to access and manage your HQ Jobs.
  • Edit Menu: Move, manipulate, copy, mark read/unread and filter your Jobs.
  • Tools Menu: Access settings, contacts and troubleshooting tools.
  • Updates: Click to update HQ or your the software on your SeeSnake equipment.
  • Help Menu: Used to get help, send bug reports and check for software updates.
  • New Button: Creates a new job.
  • Open Button: Opens an existing job that is selected.
  • Archive Button: Moves the selected job to the job archive.
  • Delete Button: Moves the selected job to the Recycle Bin.
  • The name of your computer: This is next to the HQ logo and can be changed.
  • External drives: Any USB flash drive that is plugged in and recognized will appear.
  • Job Space: This is a list of locations where your jobs are kept, archived, or recycled.
  • Equipment Locker: This lists any equipment that you have registered or used with HQ.
  • Notifications: This is the area that gives you information regarding jobs, equipment, or errors.

When you click on these areas, or use your right mouse button, several other options will appear.

The Sign In Toolbar

  • Sign In Button: After registering (click sign up or register), Sign In to your HQ account.
  • Updates: Click to update HQ or the software on your SeeSnake equipment.
  • Contacts: You can add and save contacts, customers, and inspectors.
  • Search: Use this to search for jobs, customers, and contacts.

Settings

  • Preferences: Language, Distance, and General Settings.
  • Job: Change job import and naming preferences.
  • Video: Playback and Recording Settings.
  • Overlay: Placement and Preferences for Video Overlay.
  • DVD: Colors, Custom Intros, and Regional Preferences.
  • Email: Configure email preferences to send reports via email.
  • Accounts: Edit Account HQ info, Sign in or out, Authorize/De-authorize YouTube account, or reset password.

The Job Window

When you click on a job to open it, the Job window appears. The job window consists of two distinct areas:

  • The Job Navigator on the left. The media that you select in the Job Navigator will be accented in blue and appear enlarged in the View Port to the right.
  • The Media Playback Window on the right. This is where you view, edit, annotate, or even share your media to YouTube.

Job Navigator

The Job Navigator is a collapsible pane on the left side of every Job window where you select what you want to be shown in the viewing area to the right.

1. Seesnake Live: This shows live video and audio sources available to HQ. An example would be an LT1000 laptop interface, mobile device, or laptop camera. SeeSnake Live will expand to show a live feed from whatever camera is selected.

2. Job Data: Selecting the Job Data thumbnail will make the Job Info the the active element and place it in the View Port for you to edit. You can also change the media sorting by time/distance, or change the units with the corresponding buttons.

3. Session Data: Selecting the Session Data thumbnail will make the Session Info active and place it in the View Port for you to edit. Session Data is information you want included in reports for your customers.

4. Media List: Any media you capture while doing an inspection will appear in the Media List. This includes photos and videos. Active media is highlighted in blue and enlarged in the Media Playback Window to the right. Right-clicking anywhere on media in the list will show the Media Options drop-down menu.

5. General Information: Name the job and edit basic information related to the job.

6. Customer Information: Complete the customer fields, such as address and contact info.

7. Inspector Information: Fill-in the inspector business and contact info.

*Note: The job and session information can also be edited in the report tab of HQ.

Media Playback Window

The Media Playback Window is where you view and edit media. You can also upload videos to YouTube from here.

Icon Description
Photo: Take a still picture of the video you are viewing. This picture will appear in the media list to the left and be added to the report.
 Video Clip maker Video Clip: Create a video clip from an existing video. Advance the video to the desired start point, and move the white brackets in the progress bar to select the start and end points for the video clip. Then select the Save Clip button. This will not affect the original video and the clip will be saved below it.
 Create Notes Job Notes: Write job notes related to the selected media element that appear on the job reports.
 Private Notes Private Notes: These notes are private and will not be included in any customer reports, but can be seen in HQ.
YouTube: Upload videos to YouTube and you can copy or email the link to your customers. You must have a Google account and authorize HQ.

Helpful Links: Google Setup Instructions and Upload Videos To YouTube

Photo Talk Photo Talk: Allows you to add audio commentary to a picture. A microphone is required to record your voice with the PhotoTalk.
 Photo Editor Photo Editor: The Photo Editor can be used to enlarge, rotate, change brightness/contrast, add captions, and change colors to pictures.
Email Email: Email pictures to customers from HQ. Setup Email In HQ

Creating And Distributing Job Reports

A Job Report in HQ is the output of a finished inspection Job. The report summarizes the information that may be useful for distribution that can include text, pictures, and video. There are three types of Job Reports in SeeSnake HQ:

  • Standard Report: To export, email, or print reports.
  • DVD Report: To burn a Job Report onto a DVD.
  • Upload Report: To upload your reports for online viewing.

The Report Tab below is where you select your report options.

Select the type of report you want to create from the options at the top of the report tab. Depending on what report type you select the distribution methods will change. The type of report you create will depend on the type of media you want to include and how you want to distribute the report to your customers.

Standard: Standard Reports can be emailed, printed, or exported as PDF/HTML. This type of report either encapsulates content as a PDF document, or it develops a web page in HTML format, to assist in the viewing of the Job content, including video.

Export report: Click Export to save your report as a PDF file (just text and pictures) or a webpage with video, text, and pictures.

  • To export a PDF make sure that the Save as type box is set to: Standard PDF Document (Text/Images only) (*.pdf).
  • To export as a web page (including all video and pictures), click the Export Button and Save the report as a web page (HTML Page).
  • This will create a web page with video and pictures that you can export onto a USB thumb drive for customers. They can view it just like any other web page once they insert the USB drive into the USB slot on their computer and click on the web page (HTML) file, as seen in the pictures below.
 Exporting Inspection Jobs As A Webpage
 Job Report Files: Files associated with the job including media and website formatting. Must be copied to the same location as the job report. Do not edit.
Job Report: Open this to view the job report. Your internet browser will display the report with media included.

Email report:

Make sure you setup your email in the HQ settings first. Click Email to send an email with a PDF report with pictures and text (no video). If you setup your email in the HQ settings, it will send from HQ or open your default email client to send the report.

Print report:

Click Print to print out a copy of the job. To match the report more accurately as it appears onscreen, we recommend exporting the report as a PDF and then printing the job from the PDF file.

DVD

A DVD Report collects the Job information and converts it to a format designed to be compatible with consumer DVD players. This capability is useful for report distribution and archiving reports and videos.

Icon Description
Burn: To start burning your DVD, click Burn. Your disk will start burning and you will be notified when it is done. In the mean time you can continue working on other things in SeeSnake HQ.
  Preview: To preview your DVD report and to make sure you are satisfied with it before you burn the report and distribute it via DVD.
Refresh: Click refresh to update the report with any changes before you burn it to DVD. A prompt will also ask yoy to refresh if you make changes before the DVD burning process.

Upload Reports

You can upload inspection videos and job reports online and provide customers with links to view them. HQ features YouTube uploads for videos and Ridgid Connect uploads for videos and reports.

Uploading reports does not have the inherent media file size limitations that email does, and you can share media/jobs remotely instead of giving the customer physical media like a USB flash drive or DVD.

YouTube

  • Open a job and in the Edit Tab, click on a video from the left side , then click the YouTube icon 
  • You will need to sign in to a Google account and give HQ permission to upload to YouTube and email video links in HQ using Gmail.
  • When you click the YouTube button for the first time, it will take you to an authorization page as seen below. Click allow.
  • Having trouble with this step? Read about Manual Authorization
  • The video will start uploading once authorized, and HQ will alert you when the upload is finished.
  • If you have already authorized Google uploads previously, select the YouTube button, then the upload button to start the upload.
  • Once The YouTube play button  appears on your video on the left side of HQ, you can press the YouTube button  to open the video in YouTube.
  • From the YouTube window in HQ you can email a link to the video, copy the link, or play the video back on YouTube.

Ridgid Connect

  • Ridgid Connect is a web site to upload your HQ reports that include videos, pictures, and text. You will need an account on the Ridgid Connect Website to use this feature.
  • Once you have a Ridgid Connect account, you will see a login box when you first click the Upload Report type at the top of the Playback Window.

HQ_Ridgid_Connect_Logo_smallVerify Credentials: Click the Ridgid Connect Button to verify the username and password you selected when joining the Ridgid Connect job report hosting service.

HQ_Upload_report_ButtonUpload Button: Click upload when your report is ready to be uploaded online to Ridgid Connect. You can upload full job reports, or just individual media.

Customizing Reports

In the report tab of HQ you can use the following report customization features:

  • Include your own custom logo or picture on the top of the report.
  • Change the colors of backgrounds, borders, fonts, titles, headers, and borders.
  • Change the horizontal alignment of items like text and pictures.
  • Change the size of fonts and pictures.
  • Change the visibility of any group of data, element, or section to include or exclude it from the report.
  • Edit the report text and notes from within the report template.
  • Create and save report formatting styles for future use, so you can re-use your preferred report formatting and not have to modify the default style every time.

The Custom Job Reports Toolbar

HQ_customize_reports_toolbar

1. Choose a Job Report Style:

  • You can pick one of the the default report formatting styles, or one that you created previously.

HQ_Job_reports_style_toolbar

2. Save Style Button:

  • Save a Job report style that you created, so you can re-use your preferred report formatting and not have to modify the default style every time.

3. Style Editing:

HQ_Job_reports_style_editing_toolbar

  • Click the Style Editing button to bring up the Style Editing Toolbar.
  • From the toolbar you can change the colors of backgrounds, borders, fonts, titles, headers, and borders.

Job Report Formatting Toolbars

While you are reviewing a Job in the Report Tab, click the area you wish to make a change to the formatting, and a toolbar will appear with various formatting options.

HQ_Job_reports_formatting_toolbar

1. Show or Hide the Job location address.

2. Show or Hide the customer address.

3. Show or Hide the inspector address.

4. Choose the data format or include extra data fields in the report.

5. Align the elements to left, middle, or right.

6. Change the border visibility in the report.

HQ_Job_reports_formatting_toolbar2

1. Change the visibility of the group of data, element, or section to include or exclude it from the report.

2. Change the font size for the group of data, element, or section.

3. Align the elements to left, middle, or right.

4. Change the visibility of the element label text to include or exclude it from the report.

5. Change the visibility of the element to include or exclude it from the report.

Getting Help

To get help with SeeSnake Equipment:

Select the device in the Equipment Locker.
This will bring up Product links and Support Resources.
Click these to download manuals, navigate to online support, or send support emails.

To get help with SeeSnake HQ:

Select the HQ Icon in the Job Space or click the Help Menu in the Main Toolbar.
This will bring up Product links and Support Resources.
Click these to download manuals, navigate to online support, or send support emails.

HQ_Get_help2

Sending Bug Reports

If you have a problem that you need help with or want us to know about please let us know. You can do this easily right from SeeSnake HQ. From either the Home Window or a Job Window, go to the Help Menu and select Send Bug Report.

HQ_Bug_report

1. Your Email: enter your email address (optional), this will be automatically filled out if you have configured an email address for yourself in the SeeSnake HQ Settings.

2. First Name: Enter your first name (optional).

3. Last Name: Enter your last name (optional).

4. Subject: For the subject write a briefly statement of what the problem is.

5. Description: please tell us more about the problem you’ve encountered. What happened, what you were doing when it happened, what you are seeing on the screen, etc.

6. Log File: This box will be automatically checked, we will need it to help you solve your problem.

7. Job File: If the problem is specific to the job you may want to check this box so we have more information and will be able to solve your problem faster.

8. Send: When ready, click Send and your bug report will be sent to SeeSnake Support. We will contact you shortly.

*Though some of the fields are optional, we highly recommend being as thorough as possible when submitting bug reports. The more details you can provide, the better we can help to identify and resolve your issues.

Support Site

You can find help, frequently asked questions, updates, and articles on the SeeSnake Software Support website here: SeeSnake HQ Support Site

Download Manual

Operator’s manuals for HQ and all SeeSnake Products can be found HERE