SeeSnake Support:Home/HQ Software For Windows

Customized Reporting with SeeSnake HQ

Download Latest Version of HQ

Online Manual

About HQ

HQ is a free software tool that helps you collect digital pipe inspection content and impress your customer with simple to create yet professional looking reports.

Use HQ to organize and edit jobs, store customer information, customize and distribute reports in multiple formats, and update equipment software.

HQ can be installed on PCs running Windows 7 or later. The software is translated into over 15 languages and localized for use worldwide. The 8 GB USB drive included with all SeeSnake monitors has HQ preloaded. Insert the USB drive into a PC to begin installation. You can also download the latest version of HQ here.

System Requirements

  • Windows 7, Windows 8, Windows 8.1, Windows 10.
  • Intel® Core i5 or AMD equivalent or higher. 1.84 GHz  (2.4 GHz or higher recommended)
  • 2 GB system memory (4 GB or higher recommended)
  • DirectX 9/10/11 compatible graphics integrated/dedicated with 256MB or higher (512 MB or higher dedicated graphics card recommended)
  • DirectX 9 or higher compatible sound card
  • 30 GB of disk space
  • 1 USB 2.0 port (USB 3.0 or USB Type-C Optional)
  • Screen resolution of 1024×768 (1280×800 or higher recommended)

Optional:

  • DVD burner for creating DVD reports
  • Internet connection for emailing reports, uploading reports to YouTube or RIDGID Connect, and software updates.
HQ logo

Videos

About Autolog

Learn how to record Autolog video, a compressed video format that leaves you more room for additional media.

HQ Software For Windows

Take your reports even further with customized editing available in HQ Software for Windows.

HQ FAQs

If you are unable to play video in HQ:

  • Make sure your PC meets the minimum requirements listed on our HQ support page.
  • Try using the Troubleshooting Tools located in the top left HQ toolbar from the main HQ screen. Click on Tools > Troubleshooting Tools. Run The Troubleshooting Tools. What are the results?
  • Did you try to playback the demo job that came with HQ? If that plays, the other video you are attempting to play may be corrupt, you can also try a different USB port on your computer.
  • If you are using a USB thumb drive/flash drive to record videos onto, try a different thumb drive as it is very common for them to go bad and the files on them to become corrupt. Also try re-importing the job into HQ or fixing the file using Windows Chkdisk
  • Check for a software update. Click ‘Help’  or ‘Update’ to update HQ.
  • If you are missing media from the job, you can try to recover it using the HQ feature “Recover Job Media”. From an open HQ job, select Tools > Recover Job Media. This will attempt to find any missing media from an HQ job.
  • Update your graphics card drivers on your computer from the manufacturer’s website.
  • Install HQ on a different computer and try playing the same job video. What are the results?
  • Temporarily shut down any CPU intensive software like virus scanners running in the background that may be interfering with HQ. Other open programs or processes can affect HQ performance.
  • Computers sometimes come with pre-installed software that may be interfering with video recording or playback. If you do not use this software you can uninstall it to see if HQ will perform as intended.
  • You can always try to import media into HQ by simply dragging and dropping the media into an open job.
  • You may have a 3rd party video player or video codec pack installed that is interfering with video. Try uninstalling other video players (Windows media player is ok). The video software that comes with GoPro cameras can sometimes cause issues.
  • Un-install and re-install HQ by downloading the latest version from our HQ support page.

If you are unable to see LIVE VIDEO in HQ and a RIDGID LT1000:

  • Make sure your PC meets the minimum requirements listed on our HQ support page.
  • Un-install and re-install HQ by downloading the latest version from our HQ support page.
  • Check for a software update. Click ‘Help’  or ‘Update’ to update HQ.
  • Try using the Troubleshooting Tools located in the top left HQ toolbar from the main HQ screen. Click on Tools > Troubleshooting Tools. Run The Troubleshooting Tools. What are the results?
  • If you are getting a blue screen for live video, it usually means your cable connection is no good. Verify all cable, USB, and power connections are good and try a different USB port on your computer.
  • If you are getting beeping noises or flashing lights, it may be a power issue (check battery or AC power connection) or the LT1000 may need a software (firmware update). You can update equipment via HQ or use the Troubleshooting Tools located in the top left HQ toolbar from the main HQ screen. Click on Tools > Troubleshooting Tools.
  • Install HQ on a different computer and try getting live video. If it works on a different computer, it may be something specific to that computer that would be difficult to diagnose.
  • Temporarily shut down any CPU intensive software like antivirus programs running in the background that may be interfering with HQ. Other open programs or processes can affect HQ performance.
  • Computers sometimes come with pre-installed software that may be interfering with video recording or playback. If you do not use this software you can uninstall it to see if HQ will perform as intended.
  • Change the video settings by going to Settings > Video. Make sure “Allow HQ to control video codec” is selected.
  • You can change video quality by going to Settings > Video and change the quality from MP4 to MJPEG.
  • You may have 3rd party video software that is interfering with video. Try uninstalling other video players (Windows media player is ok). The video software that comes with GoPro cameras can sometimes cause issues.
  • Update your graphics card drivers on your computer from the manufacturer’s website.
  • Clean your camera head to assure your live video is viewable.
  • Try running HQ as administrator and make sure you have access to the job space location.
  • Disable any webcams or cameras built into the computer and its drivers in your Windows device manager.
  • Turn of your laptops sleep mode so video does not get interrupted.
  • Try to manually install the LT1000 drivers. Directions are here: http://hq.RIDGID.com/question/how-to-manually-reinstall-lt1000-drivers/

If none of these suggestions work for you, please send us a Bug Report (Help > Send Bug Report) and include the answers to the questions below:

  • Are you able to record live video?
  • Are you able to play back recorded video in HQ?
  • If you imported video into HQ, what is the source of the video?
  • What equipment are you using (Model names, numbers)?
  • Can this video be played outside of SeeSnake HQ in Microsoft Windows? If so is the quality ok?
  • Is there other video software installed on your computer that may be interfering with HQ?
  • Are you able to play other videos in HQ, like the Demo Job that came pre-loaded with HQ?

Typically when there is a DVD or Job Exporting problem it is caused by one following things:

  • A hardware issue with the DVD burner on your computer. We recommend installing SeeSnake HQ on a different computer and try to burn a job onto a DVD to determine if it is a DVD burner hardware issue.
  • A media issue. Confirm that you are using compatible blank DVD’s for your DVD burner. Also USB Thumb drives can malfunction over time, so reformat and replace them at regular intervals.
  • A file issue. Confirm that your job or video files are not too large for the DVD disc’s capacity. In addition, make sure proper shutdown procedures are used on your equipment so all media is saved correctly.
  • A virus scanner, different DVD burning software, or other resource intensive application is running at the same time as SeeSnake HQ. Please temporarily shut down any of these programs the next time you try to burn a DVD in SeeSnake HQ.
  • Certain AMD Vision Computer Processors cause issues with video transcoding. We recommend computers equipped with Intel processors.
  • If you wish to use a different program to copy your media and videos (in MP4 or AVI format) with, simply drag and drop the videos and pictures in HQ from the left hand column of an open job to your windows desktop or other location on your computer so that you may burn them to disk using other software or put them on a USB thumb drive. You can also right-click a job from the main HQ screen and choose “Export Media”. The videos are usually in MP4 or AVI format.
  • There are many other options besides DVD to deliver your reports. Please see the HQ online manual for instructions on distributing HQ job reports here: Distributing HQ Job Reports

Updating SeeSnake Software For Your Equipment

This article describes how to update the software on all RIDGID® SeeSnake® inspection monitors.

Critical and routine software updates for all SeeSnake Monitors are released through HQ software. You can also download the update directly. You need a USB drive to update. The drive must have FAT32 formatting, 2 GB of available space, and a capacity less than 32 GB.

1. Open HQ on a PC. 

Click here if you don’t have HQ installed. 

2. Click the Update button in the top-right corner and select the product. 
3. Follow the steps in HQ.
4. Power on the monitor and follow the on-screen prompts.

The process will take several minutes and the monitor reboots several times. The monitor alerts you when installation is complete. If the update is not successful, please try again. You can force an update by pressing the still photo key while powering on the device.

You can update some SeeSnake equipment without using HQ by downloading the update files from this website.

1. Insert a USB drive into the computer.

The drive must have FAT32 formatting, 2 GB of available space, and a capacity less than 32 GB.

2. Click the button to download the latest CSx software update.

3. Extract the contents of the ZIP file into the root directory of the inserted USB.

4. Safely eject the USB drive from the computer and insert it into your CSx Monitor.

5. Power on the CSx Monitor and follow the on-screen prompts.

The process will take several minutes and the monitor reboots several times. The monitor alerts you when installation is complete. If the update is not successful, please try again. You can force an update by pressing the still photo key while powering on the device.

Automatic Updates

HQ will automatically notify you when there is an update available.

Once notified, you can agree to the update and it will be installed.

Manual Updates

Select Updates from the main HQ screen and then select Update HQ Software.

  1. From the SeeSnake HQ Home screen, click on the Job Space that you want to make backup copies of your inspection jobs from. The Job Space will be highlighted in blue when selected.
  2. Plug in a USB drive to make copies of your jobs to. You will see a USB drive icon with a drive letter once HQ recognizes the drive. You can use an External USB Hard Drive or USB Flash Drive.
  3. To move a Job to your storage device, simply select the job (the job select box will have an ‘X’ and the job will be highlighted when selected), and then drag the desired Job into the drive.
  4. On the storage drive, the copied Job will appear as a folder, labeled with the appropriate Job date or name.
  5. Make sure when dragging the jobs to the USB, you see a caption that says “Copy”, as shown in the picture below. If it says “Move”, you are not copying the job, you are moving the original.
  6. This will keep the jobs in the original HQ format and you can import these jobs back into HQ whenever necessary. Some examples would be if you have computer problems and lose data, or replace your hard drive, you can simply import these jobs from the drive you saved them to.
  7. You can always just Archive your jobs within HQ by moving them to the Job Archive. Right click and choose Archive Job.

Distributing Reports

HQ offers multiple ways to distribute reports: as a PDF that can be printed and emailed, as a webpage, or as a multimedia report for online or DVD distribution.

PDF Reports

  • When you’re ready to create a PDF of an inspection report, click the Export button under the Report tab and save the file as a PDF.
  • You can also click Email to send an email of the PDF straight from HQ. See the FAQ about configuring HQ to email reports.
  • To print a report, Click Print to print a copy of the PDF.

Webpage

  • To create a webpage of the report, click the Export button and save the file as a webpage.

Multimedia Reports

DVD

  1. Click the DVD tab in the ribbon at the top.
  2. Insert a blank DVD-R into the computer’s DVD drive.
  3. Click Burn and select the DVD drive from the drop-down menu.

Digital Uploads

YouTube

  • The first time it will take you to a Google authorization page, where you agree to allow HQ to upload to YouTube.
  • To upload media to other cloud storage or hosting services like DropBox, icloud, Google Drive, etc. you just need to export the media out of HQ

Ridgid Connect

Content in HQ can be uploaded to RIDGID­Connect, an online service for storing and sharing inspection media and reports. An account is required to use RIDGIDConnect features.

  1. Click the Upload tab in the ribbon at the top.
  2. Type in your RIDGIDConnect username and password under the ribbon.
  3. Select the Report Type drop-down menu to choose whether to upload a report or individual media captures.
  4. Fill in any additional information you want to enter.
  5. Click Upload and follow the prompt to verify your RIDGIDConnect credentials.

Visit www.RIDGIDconnect.com to learn more.

The Ridgid Connect Interface

 

How do I upload videos to YouTube in HQ?

  • Open a job and in the Edit Tab, click on a video from the left side , then click the YouTube icon

  • You will need to sign in to a Google account and give HQ permission to upload to YouTube.
  • When you click the YouTube button for the first time, it will take you to an authorization page as seen below. Click allow.
  • Having trouble with this step? Read about Manual Authorization

 

Authorize

 

  • The video will start uploading once authorized, and HQ will alert you when the upload is finished.
  • Click the link in the alert to open the video in YouTube.

 

 

  • Once The YouTube play button  appears on your video on the left side of HQ, you can press the YouTube button  to open the video in YouTube.

 

 

 

 

  •  You can manually authorize YouTube uploading in the HQ Settings.
  • This is helpful if you have multiple Google accounts and need to switch between them. See the picture below.

 

 

  • To remove permissions for HQ YouTube uploading or select a different Google account to use for YouTube uploads, you can select the Deauthorize button in the HQ settings.
  • This will take you to the Google page where you would select Remove. You must do this before you can authorize a different Google account.
  • To add a different Google account for YouTube uploading, select Authorize in HQ settings, and it will take you to the Google authorization page explained in previous steps.

 

 

  • To upload media to other cloud storage or hosting services like DropBox, iCloud, Google Drive, etc. you first need to export the media out of HQ

If you are having problems with HQ and cannot resolve the issue with information contained on this site, you can get help.

The best way to get help is to Send a Bug Report within SeeSnake HQ. To do this, follow the instructions below:

  • From the Job window, click on Help > Send Bug Report.
  • Fill out the fields in the form that pops up. The more information you provide, the better we can communicate with you and please include an email address to contact you with.
  • Make sure the boxes are checked to include any logs or jobs at the bottom of the Bug Report Window.
  • Click Send to submit the bug report.
  • If sending a Job in addition to the report, be sure to allow the uploader to fully submit the Job file before exiting. Job files can be quite large, depending on the amount of media within them, so be prepared to wait for a bit with larger Jobs.
  • Once The Customer Support Team receives the bug report, we will review it and respond.

  • Even if you are using new USB thumb drives, they can be the source of corrupt files or read-only jobs during HQ job imports.
  • For good practice, please format all USB thumb drives to FAT32 format before the first use and regularly after that.
  • When HQ shows corrupt jobs/files, you can use the built in Windows Check Disk utility to repair them on the USB thumb drive, and then try to re-import the jobs into HQ. See the picture below for Check Disk instructions. This is done outside of HQ, in Windows.

Windows_Chkdsk

  • Sometimes simply deleting the job in HQ and then and re-importing it from the USB thumb drive will work.
  • If there is missing media in your job, there is a built in HQ utility to recover job media. To use this, In an open HQ job from the top left toolbar, click Tools > Recover Job Media.
  • Battery or power interruptions/fluctuations on recording equipment or loose USB thumb drive plug-in connections can also cause corrupt files.
  • If you see a padlock icon HQ_readonly on your job, it means that job is read-only and sometimes cannot be opened or edited in HQ. This is usually caused by one of two things:
  • A bad USB thumb drive (see instructions above for repair/reformat options), or use a different thumb drive.
  • HQ might not have access to the job space (where the job files are stored on your computer) or the job space location has been moved.
  • You can create or change HQ job space. See the FAQ in this list that explains HQ Job Space.
  • The default location where HQ jobs are stored on your computer is in the following directory: C:\ProgramData\SeeSnake\SeeSnakeHQ\Jobs
  • Make sure HQ and you as a user on that computer have access/security permission to access the above directory. See your IT pro for access or try to run HQ as Administrator.
  • If you right-click on any job from the main HQ job listing screen, select properties to show you the location of where that job is stored on your device.

HQ_Job_Location

Yes. You can switch back to the previous version of HQ by clicking HELP and then VIEW/DOWNLOAD OLDER VERSIONS.

Before you uninstall the current version of HQ, make sure you have backup copies of all your HQ jobs. You can then uninstall HQ and download the previous version.

 

old version HQ download

If you are having trouble with the automatic driver install through Windows, you can manually point Windows to the LT1000drivers already located on your machine as a result of the SeeSnake HQ installation. This is often the solution to many video issues as well.

  1. Plug in and turn on the LT1000.
  2. Right-click on My Computer and select Properties.
  3. Navigate to Hardware > Device Manager.
  4. From here, expand the Sound, video and game controllers section.
  5. Locate the SeeSnake USB Video Camera selection.
  6. Right-click that and choose Update Driver Software.
  7. Choose the Browse my computer for driver software.
  8. Use the pathway: C:\Program Files(x86)\SeeSnake\SeeSnake HQ\LT1000 Drivers\32 (or \64 if you have a 64-bit system).
  9. Let the machine run the update process.
  10. If you are using Windows XP, there may be another device listed under Sound, video and game controllers that relates to the LT1000 as well; something titled with the labelSeeSnake Camera Peripheral; if you see this device, follow the same instructions to update the driver software for that as well.
  11. Restart your machine.
  12. Plug in and power on your LT1000 and run SeeSnake HQ.
  13. If this does not work, you can use the HQ Troubleshooting Tools. Click Tools > Troubleshooting Tools.

Ensure that the report was properly saved by opening up SeeSnake HQ and navigating to the Reports tab. If the report looks good, try to re-distribute the report to your customer.

If they are still having problems, try distributing the report with a different method (email, print, DVD, or upload).

Make sure your version of HQ is updated.

If you continue to have problems getting your report to your customer, contact SeeSnake HQ support by clicking Help within the program.

  1. Open up your Microsoft Internet Explorer Browser.
  2. Select Tools.
  3. Select Internet Options.
  4. Select The Content Tab.
  5. Select Publishers.
  6. Select Untrusted Publishers.
  7. Highlight anything saying SeekTech or SeeScan and select Remove.
  8. Repeat in the Certificates button on the Content tab.
  9. Now re-download HQ and attempt an install.
  10. Make sure when the Setup Security Warning box pops up that you select “Always run software from SeekTech or SeeScan”.
  11. Complete the install process
  12. Open HQ
  13. Now SeekTech or SeeScan should appear under Trusted Publishers in that content tab under publishers.

To make sure your report looks the same when printed:

  • Export your report to your computer by pressing the export button.
  • Name your report in the file name field
  • Save report as a PDF file (not a webpage)
  • Open the report with Free Adobe Reader. It’s a free download here: http://get2.adobe.com/reader/
  • Print your job from Adobe Reader.

To allow HQ to access the Equipment Locker, validate sign in credentials, and update to the latest software for your Ridgid SeeSnake and SeeScan equipment, you must have internet access.

Also, you must configure your firewall/proxy/security software to allow HQ to access the following sites:

https://registration.seesnake.com

https://signup.seesnake.com

http://update.seesnake.com

https://update.seesnake.com

http://software.seesnake.com

http://hq.seesnake.com/

http://manuals.seesnake.com/

It’s likely that the installation is being halted by the Windows UAC (User Account Control) verification window that pops up during most software installs.

This is a security prompt from Windows that wants the user to verify the installation. However, this prompt often comes up in the background, not making itself very clear to the user. Windows requires that the user acknowledge the prompt before proceeding with the installation. As a result, the installation will be paused until the UAC is passed.

In order to find the UAC window, you can either click through or minimize any open windows; or you can look at your Taskbar and locate an icon (it may be flashing) that looks like a shield. Once you’ve located it, simply acknowledge that you would like to continue with the install and you should be set.

  • You can organize/sort your Jobs by clicking on a column header, e.g. Date and Start Time, in the Home screen.
  • This allows you to sort your Jobs by that information type.
  • Clicking the header will switch between ascending and descending sorting orders.
  • To edit the available column headers, right-click the headers area and select Show/Hide Column Headers.
  • The ‘Export’ option in SeeSnake HQ is designed to create a web browser compatible, HTML multimedia report.
  • In order for this report to function correctly, you MUST keep both the ‘InspectionReport.html’ file AND the ‘InspectionReport_files’ folder in the same location. DO NOT RENAME THESE FILES.
  • Assuming they are in the same location, simply opening up the ‘InspectionReport.html’ file in any web browser should result in a viewable multimedia report.
  • *NOTE Older versions of HQ exported HTML reports with flash based video that may not be playable in modern web browsers. Please update your version of HQ.

To share jobs between multiple machines such as a desktop and laptop computer you can use a common shared location such as a shared drive or network location.

  • You first have to add Job Space in HQ.
  • HQ add job space In HQ choose “Add Job Space” from the toolbar on both computers by right-clicking on your Job Space or Computer nickname in HQ.

HQ add job space right click

  • In the selection window that appears, choose a folder from the shared location that both computers have access to.

 

  • HQ shared job space HQ will find and add the jobs from the shared location on both machines.

 

  • When these computers are both connected to the shared location, they can open, delete and manipulate the jobs in this location.

 

  • HQ shared job space locked  If a computer is brought into the field away from the shared location, the shared location will appear locked.

 

  • The jobs in this location cannot be opened or edited but will show up in the job space list so that the user knows which ones are offline.

 

  • Once new jobs have been created on a computer in the field and brought back into the office where the shared location is, the offline job space will unlock and the user can simply drag and drop any new jobs into the shared location or cut/copy and paste them using the right click menu.

HQ job space right click

  • The same goes for editing a job in the field, if the user needs to edit a job outside the office, create a copy on the laptop Jobs job space, edit it and then copy the newly edited version to the shared location once the location is online.

 

  • Using these methods should prevent jobs from becoming fragmented and missing sessions and media when manually copied over from one location to another.  HQ needs to be aware of the changes made to jobs to properly maintain the file locations.

DO NOT edit job data outside of HQ!

Change the default Job Space:

  • To change the default location of where your jobs are stored, right-click on the jobs folder and select “Change Location”

HQ_Jobspace

  • Select the location or folder on your device where you want jobs to be saved to.

Setting up email in HQ and the process to email job reports.

  • Click on Settings and go to Email Settings

Email settings

If you use Microsoft Outlook/Outlook express or corporate email:

  • You can usually just choose “Configure Default Email Client”.
  • Put Your email address field.
  • Click the “Send Test Email” Button.
  • It will show when the email is sent and you can check your inbox for an email confirmation.

If you use POP3 Email:

  • Click configure your POP3 account.
  • Get the POP3 account info from your email provider and fill in the POP 3 fields.

Email POP3

  • Click the “Send Test Email” Button.
  • It will show when the email is sent and you can check your inbox for an email confirmation.

If you use GMAIL:

Google Settings

  • In HQ put your Gmail address in the email settings field and click the “Send Test Email” Button.
  • It will show when the email is sent and you can check your Gmail inbox for an email confirmation.

  • If you’re not sure what kind of email you use (corporate, POP3, or Gmail), contact your email provider or IT professional to assist in setting up email capability.

 

Sending reports via email in HQ.

 

* The report must include only very short and small sized videos because your email has an extremely small file size limit. You can shorten videos using the built-in HQ clip editor to make the video file sizes smaller and suitable for sending via email. You can also substitute videos with Photo Talk or Autolog for smaller file sizes. See the email size limit chart at the bottom of the page. You also need internet access to email a report or media. This is not a limitation of HQ.

 

  • Export the HQ media from HQ to a location on your computer by selecting a job (click the box on the far left of the job columns. Right-click and select Export Job Media.

 

HQ_export_media

 

  • Select the location to save media to, and click Select Folder.

 

HQ select folder

 

  • Open the HQ job, and from the Report Tab, select Email.

 

HQ_email_tab

 

  • Put the email address of the customer in the To Field. Click the Add Button to attach the media you previously exported. Write your email Subject and Body. Click Send.

 

HQ_email_interface

From the Tools Menu, select Contacts, and then Add. You can also edit and remove contacts.



You can add contacts from an open job in the Edit Tab of the report, when you click on the job/session information.




You can export the media from your HQ job by simply right clicking on the job from the main HQ screen, and selecting “Export Media”.

HQ-export-media_main-screen

 

You can also drag and drop individual media out of HQ from the Job Navigator (The left hand column of an open job). This will only make a copy of the media to the location you drag it to, it will not remove or delete the media.

 

HQ_click-drag-export-media

 

You can also to share media via email or online to RIDGIDConnect by right-clicking on the desired media and selecting Send To. Remember, you must configure HQ before you can send email from within the HQ software. See the Email Setup FAQ on this page.

 

HQ_send_media_to

To change job names individually, simply right-click the job name from the main HQ job list and select Rename Job.
HQ_Rename_Job

This can also be done in an open job from the HQ Edit Tab, in the Name Field, under Job Information.

HQ open job rename

If you want to change the default naming format in HQ on job import, you can go to the HQ Job Settings. See the picture below.

HQ_Settings_job_name

There are 5 choices for your job name on import:

  1. Job Start Time – Uses the time you started the job as the name of the job.
  2. Customer Name – Uses the customer name you input in the field from your SeeSnake equipment.
  3. Street Address – Uses the customer address you input in the field from your SeeSnake equipment.
  4. Equipment Name – Uses the name of the SeeSnake Equipment you used to perform the inspection.
  5. Custom Name – Uses any naming parameter you choose.

*NOTE – If you select “Change media file names to job on import”, all your associated job media will contain the specified job name.

 

Examples of all the different job name options as they appear in HQ are shown below.

HQ job name options